/breezy/unstable

To get this branch, use:
bzr branch https://code.breezy-vcs.org/breezy/unstable

« back to all changes in this revision

Viewing changes to breezy/help_topics/en/missing-extensions.txt

Merge trunk, address review comments.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Missing Extensions
 
2
==================
 
3
 
 
4
Breezy gives a warning if it failed to load some compiled extensions. (See
 
5
http://bazaarvcs.wordpress.com/2009/09/17/extension-warnings/ for background.)
 
6
 
 
7
This may indicate either that there's been a problem installing or packaging
 
8
Breezy, or it may just be a case where you don't want to use the compiled
 
9
extensions.
 
10
 
 
11
1. If you installed Breezy from an official binary package or a distribution
 
12
and you're seeing this warning, please report a bug.
 
13
 
 
14
2. If you're running Breezy from a source tree or tarball, please run 'make' in
 
15
that directory to compile the extensions. You should do this every time you
 
16
update the tree. To do this you will need some build dependencies installed
 
17
including make, a C compiler, and the Python header files.
 
18
 
 
19
3. If you can't or don't want to build the extensions, add this line to
 
20
bazaar.conf (whose location is shown by 'brz --version')::
 
21
 
 
22
  suppress_warnings=missing_extensions
 
23
 
 
24
Breezy will work normally but some operations may be slower.
 
25
 
 
26
The specific modules that failed, and why, are listed in .brz.log.